Select Page

IEMicrosoft announced that it was made aware of a vulnerability in Internet Explorer that could be exploited to remotely execute code on your computer. Nearly all versions of Internet Explorer are affected. We suggest that you use another browser, such as Chrome, Firefox, or Safari until a security update is available for Internet Explorer. 

The vulnerability has already caused issues with computers used by the US Government and financial institutions. This problem, a hole Internet Explorer’s security architecture, allows a website to execute code on a user’s machine. Internet Explorer users often struggle with add-ons that have been installed unintentionally or without the users’ permission. In theory, a malicious add-on could be used to redirect a browser to a new website where this newly discovered threat could be employed. The malicious code could be used to harm your computer, or steal your private information.

Today’s news should also serve as a caution to Windows XP users. Microsoft has ended support for Windows XP, and has announced that no security patches will be issued for the operating system. Now would be a good time for Microsoft Windows XP users to consider upgrading to Windows 7, or Windows 8.